Register    Login    Forum    Search    FAQ    Donate    Amazon Affiliate

Board index » Technical Help




Post new topic Reply to topic  [ 30 posts ]  Go to page 1, 2  Next
Author Message
 Post Posted: Mon May 29, 2017 6:13 am 
Offline
User avatar

Joined: Fri Jul 17, 2015 7:22 pm
Posts: 1391
Location: S.W. Wales
I'm trying to troubleshoot why TM on my Mac mini (late 2014, macOS Sierra 10.12.5 with Server 5.3.1) is not running hourly. I have been through Pondini's TM site following links that look appropriate but so far, no joy. Backups are set to be automatic in Settings. I can run it manually.

The mini was backing up happily before I put Server on. I am not entirely sure that the hourly backups stopped coincidentally with that installation.

I have:
- deselected the TM HDD (a 500GB USB drive), reselected it and tested.
- deselected, erased and reselected, tested. The initial backup runs, there is 332GB of 500GB free. I can enter TM and browse that solitary backup.

The Next Backup tag is stated as, say, 07:15, but at that time, no backup runs and it changes to 08:15, and so on.

Have I missed anything? Do I need to check anything else? Is it Server causing this glitch? The TM service in Server is running and is happily backing up my MBPr but I would like the mini to back itself up as well. Thanks for reading.


Last edited by loughor on Tue May 30, 2017 4:23 am, edited 2 times in total.

Top 
 Profile  
 
 Post Posted: Mon May 29, 2017 9:15 am 
Offline
User avatar

Joined: Wed Oct 06, 2010 8:27 pm
Posts: 5140
Location: Cumberland
That sounds a bit odd. You can monitor what TM is doing using Time Machine Buddy which is a widget. I have used Amnesty Singles to produce Time Machine Buddy standalone application, which you can download from HERE.

Image

Naturally your Gatekeeper will tell you it is evil and damaged and nasty since it doesn't comply with Apple's new security regime, it isn't an Apple signed application. - But it isn't evil. You'll have to allow it in your security preferences, or bypass them, to get past gatekeeper.

Or you could just use the widget, search for it on the App Store, if it's there.

This is a copy of the log that occurred last night including some error messages. I am backing my MacBook Pro over the local network to an external disk called "Time-Tunnel" mounted on the MacMini, and my MBP's hard disk has been renamed "Mavericks" - (to get your head around the messages)

Time Machine Buddy wrote:
Starting automatic backup
Attempting to mount network destination URL: afp: //davidhodsman@MacMini._afpovertcp._tcp.local/Time-Tunnel
Mounted network destination at mount point: /Volumes/Time-Tunnel using URL: afp: //davidhodsman@MacMini._afpovertcp._tcp.local/Time-Tunnel
Disk image /Volumes/Time-Tunnel/MBP.sparsebundle mounted at: /Volumes/Time Machine Backups
Backing up to /dev/disk4s2: /Volumes/Time Machine Backups/Backups.backupdb
Deep event scan at path:/Users/davidhodsman/Pictures/~iPhoto Library~ reason:must scan subdirs|missed reservation|file event|
Finished scan
Not using file event preflight for Mavericks
Found 1434 files (1.67 GB) needing backup
3.67 GB required (including padding), 631.03 GB available
Error: (-8084) SrcErr:YES Copying /Users/davidhodsman/Library/Keychains/3E31A0A9-8F0E-5ED6-92D5-801211607759/keychain-2.db-wal to (null)
Copied 1919 items (1.67 GB) from volume Mavericks. Linked 12500.
Will copy (4.5 MB) from Mavericks
Found 108 files (4.5 MB) needing backup
1.7 GB required (including padding), 629.05 GB available
Copied 195 items (5.3 MB) from volume Mavericks. Linked 1683.
Created new backup: 2017-05-28-232435
Starting post-backup thinning
No post-backup thinning needed: no expired backups exist
Backup completed successfully.
Ejected Time Machine disk image: /Volumes/Time-Tunnel/MBP.sparsebundle
Ejected Time Machine network volume.


That will get you a lot of useful information that you could also find in Console I guess, but I can't advise you how to use Console - it always confuses the heck out of me. It does have a search function though.

That should tell you where the problem lies, or at least give you a pretty good clue.

Alternatively, use one of the alternative third-party Time Machine Editor applications, I'm using this one: TimeMachineEditor which is "set once and forget" in use, you only run it when you want to change the schedule, then quit the application until the next time you want to edit the schedule.

_________________
......................1952
...............Effie Madge Mabel Biddie
...................See them on the beach
......................Or in New York City

.............Tina Louise & Hazel & Mavis
Can you name, name, name, name them all today
Can you name, name, name, name them all today

......................


Top 
 Profile  
 
 Post Posted: Mon May 29, 2017 9:55 am 
Offline
User avatar

Joined: Fri Jul 17, 2015 7:22 pm
Posts: 1391
Location: S.W. Wales
Thanks. I grabbed the Dropbox one and put it on the mini. I opened it then did a manual TM backup, which worked. Buddy reports "No Time Machine information found" both before and after the run (I did Refresh Buddy).


Top 
 Profile  
 
 Post Posted: Mon May 29, 2017 9:57 am 
Offline
User avatar

Joined: Wed Oct 06, 2010 8:27 pm
Posts: 5140
Location: Cumberland
Don't know. Perhaps Sierra works differently and can't use it, I don't know. It works just fine in Mavericks.

_________________
......................1952
...............Effie Madge Mabel Biddie
...................See them on the beach
......................Or in New York City

.............Tina Louise & Hazel & Mavis
Can you name, name, name, name them all today
Can you name, name, name, name them all today

......................


Top 
 Profile  
 
 Post Posted: Mon May 29, 2017 10:54 am 
Offline
User avatar

Joined: Fri Jul 17, 2015 7:22 pm
Posts: 1391
Location: S.W. Wales
I appreciate the responses regardless of success. I'm having time away from it for a while. It helps keep me calm. It isn't like it is breaking everything but I like solving problems. I bet it is Server so I'll start with more searches along those lines.

You know, the thing I have not tried is turning it off and on again. I will resume there, but Netflix and a cup of PG first.


Top 
 Profile  
 
 Post Posted: Mon May 29, 2017 11:00 am 
Offline
User avatar

Joined: Wed Oct 06, 2010 8:27 pm
Posts: 5140
Location: Cumberland
REBOOT!!!

ALWAYS No. 1 Priority

Then if no improvement, you could try switching TM off in it's prefs, and replacing the schedule with one generated by TME. Possibly.

_________________
......................1952
...............Effie Madge Mabel Biddie
...................See them on the beach
......................Or in New York City

.............Tina Louise & Hazel & Mavis
Can you name, name, name, name them all today
Can you name, name, name, name them all today

......................


Top 
 Profile  
 
 Post Posted: Mon May 29, 2017 1:36 pm 
Offline
User avatar

Joined: Fri Jul 17, 2015 7:22 pm
Posts: 1391
Location: S.W. Wales
I did reboot it a couple of hours ago. When I got back in, it started backup straight away and then did the next two hourly backups on schedule.

I really should have tried this much sooner. I had to do it quite often with Windows (desktop, not my server). I guess these last years of Apple have made me forget the bleedin' obvious. I'll edit the first post title.

By the way, that utility still didn't see any information so I binned it but I'll keep the zip around, thanks.


Top 
 Profile  
 
 Post Posted: Tue May 30, 2017 4:26 am 
Offline
User avatar

Joined: Fri Jul 17, 2015 7:22 pm
Posts: 1391
Location: S.W. Wales
I typed too soon. It did two more backups after my post above and then started failing again. Rebooting every few hours is not an option, really. I'll report back if I get any more information.


Top 
 Profile  
 
 Post Posted: Sun Jun 04, 2017 3:10 pm 
Offline
User avatar

Joined: Fri Jul 17, 2015 7:22 pm
Posts: 1391
Location: S.W. Wales
Talking too soon time.

I did manual backups for a while. Yesterday I noticed Plex Server on the mini wasn't updating the library so I went back to the mini. I stopped Server then restarted with it closed. TM started an immediate hourly backup. I left it and it carried on doing the business so I restarted Server. So far, it is all ticking along nicely, and I got the Plex library updated as well.

I very much doubt that Plex or Server were causing the hiccups. Things sometimes just sort themselves, BUT (a big but) I'll see how it goes over the next week or so.


Top 
 Profile  
 
 Post Posted: Fri Jun 30, 2017 10:34 am 
Offline
User avatar

Joined: Fri Jul 17, 2015 7:22 pm
Posts: 1391
Location: S.W. Wales
Just to say that the mini is still not completely happy. I reboot it and TM starts, then runs for one backup or maybe two days before it loses the will to actually do the job any more. Reboot and so on. I still have no idea what is going on but I'll just put up with it and see if High Sierra smooths things out.


Top 
 Profile  
 
 Post Posted: Fri Jul 21, 2017 12:42 pm 
Offline
User avatar

Joined: Wed Oct 06, 2010 8:27 pm
Posts: 5140
Location: Cumberland
How is your Time Machine backup disk connected to your Mac?

_________________
......................1952
...............Effie Madge Mabel Biddie
...................See them on the beach
......................Or in New York City

.............Tina Louise & Hazel & Mavis
Can you name, name, name, name them all today
Can you name, name, name, name them all today

......................


Top 
 Profile  
 
 Post Posted: Fri Jul 21, 2017 1:18 pm 
Offline
User avatar

Joined: Fri Jul 17, 2015 7:22 pm
Posts: 1391
Location: S.W. Wales
USB.


Top 
 Profile  
 
 Post Posted: Fri Jul 21, 2017 2:21 pm 
Offline
User avatar

Joined: Wed Oct 06, 2010 8:27 pm
Posts: 5140
Location: Cumberland
If Time Machine is not being triggered automatically try an alternative way of triggering it. Such as this.

TimeMachineEditor
Requires OS X 10.9 or newer

It works perfectly in Mavericks, should be okay for your system. Worth a try perhaps.

_________________
......................1952
...............Effie Madge Mabel Biddie
...................See them on the beach
......................Or in New York City

.............Tina Louise & Hazel & Mavis
Can you name, name, name, name them all today
Can you name, name, name, name them all today

......................


Top 
 Profile  
 
 Post Posted: Fri Jul 21, 2017 2:48 pm 
Offline
User avatar

Joined: Fri Jul 17, 2015 7:22 pm
Posts: 1391
Location: S.W. Wales
Good suggestion. Thanks. Once I sort Plex Server so that works without a network share, the job in hand, I'll look again at TM. I'll finish the data copying this evening. There's a lot of data.


Top 
 Profile  
 
 Post Posted: Fri Jul 21, 2017 5:04 pm 
Offline
User avatar

Joined: Fri Jul 17, 2015 7:22 pm
Posts: 1391
Location: S.W. Wales
Now the NAS is completely out of the picture and Plex has local USB files, I'll leave up and see how TM behaves. If it runs hourly over three days, it will be promising.


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 30 posts ]  Go to page 1, 2  Next

Board index » Technical Help


Who is online

Users browsing this forum: No registered users and 1 guest

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 

HTML tutorial